Since 4.2.1 contained this critical panel bug, we did a quick 4.2.1.1 release yesterday, which fixes the panel issue. All users of Xfce 4.2.1 should upgrade to 4.2.1.1. Updated installers are available from Xfce installers website.